Content Explorer tree view

Expedited help in resolving bugs for Sense/Net Enterprise Licence holders
maleczkim
Sense/Net Community Member
Sense/Net Community Member
Posts: 20
Joined: Tue Dec 02, 2008 11:52 am

Content Explorer tree view

Postby maleczkim » Wed Feb 17, 2010 1:29 pm

Dear Sense/Net!

I've always been wondering why the tree view in the Content Explorer is loading the plus icons and lines so slowly. Now I got the answer: for every plus icon and elbow line the extjs framework tries to load an image from http://extjs.com/s.gif, that redirects with HTTP 301 to http://www.extjs.com/s.gif. This is why the image cannot be cached, and for each small icon this means two extra HTTP requests.

My solution is to modify the extjs code and replace the URL to http://www.mycompaniesdomain.com/Root/S ... /img/s.gif.

Márton

daniel.jozsef
Sense/Net Community Contributor
Sense/Net Community Contributor
Posts: 198
Joined: Mon Apr 20, 2009 10:18 pm

Re: Content Explorer tree view

Postby daniel.jozsef » Mon Feb 22, 2010 11:28 am

Hello!

This is a weird occurrence, as we have fixed this issue quite long ago. It should work correctly in beta43.
Which version of Sense/Net are you using?

Still, if you need a hotfix, add this line to the beginning of SN.GUI.js:

Ext.BLANK_IMAGE_URL = '/JS/ext30/resources/images/default/s.gif';

maleczkim
Sense/Net Community Member
Sense/Net Community Member
Posts: 20
Joined: Tue Dec 02, 2008 11:52 am

Re: Content Explorer tree view

Postby maleczkim » Tue Mar 23, 2010 5:25 pm

Hello,

We used the Beta3 version then.

Márton


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest